
BidBest

Minimum Requirements

Mac 68020 CPU or later. This excludes  the original Mac, Mac SE, Mac Plus, Mac Classic, and 
PowerBook 100.

 Mac Classic II, Mac Color Classic, Mac SE/30, and the Mac LC series should be OK.

You must be running at least System 7.

Overview

This is the sequence of steps you’ll follow in doing a monthly bid –

Step One: 
Download the month's Bidpack for your equipment and domicile from the FedEx website. 
You may wish to download the appropriate Bid Seniority List as well, to calculate how 
many bid choices you need to input.

The FedEx website is located at:
http://pilot.fedex.com

Follow the links to the bid pack area. You will need to log on: use your employee number 
as a password (no leading zeros) and your current VIPS password.

Find the month and aircraft you are interested in. In each aircraft area there will be several 
different files you can download. At the time of this writing, the files for the 
B-727 were named
Bid Pack (followed by an icon for “pdf,” which means “Adobe Acrobat file”
Bid Lines & Seniority Lists (followed by an icon that looks like a vise)
Bid Lines
Seniority List

You do NOT want the .pdf file. BidBest can’t read Acrobat files. If you wish, you can 
download the “vise” file – it’s a “zip”-compressed file that is a little smaller than the 
uncompressed version and so will download a little faster. However, you will need Stuffit 
Deluxe or a similar file compression program in order to decompress it, and you may find 
it more convenient to just download the uncompressed file, which is the one named “Bid 
Lines.”

To download the file in Internet Explorer, just click on its link. It will place the downloaded 
file on your Desktop, after which you can drag it to wherever you want. To download the 
file using Netscape Navigator or Communicator, hold down the Option key as you click on 
the link. This should allow you to specify where on your computer you want the file to be 
stored.

Step Two:
Uncompress the file if necessary.
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Step Three:
Start up BidBest, which will use the downloaded Bidpack file to create a Bid Worksheet 
document.

Step Four:
Arrange your bid choices using BidBest to analyze the month's bid lines. Print out the 
choices, if desired.

Step Five:
Send your bid choices to VIPS using either phone VIPS or online VIPS (Note: recent 
versions of MacLynx have the ability to read BidBest Bid Worksheet documents, and send a 
list of bid choices to VIPS automatically).

Step Six:
After the bid is awarded, you may want to download the Bid Award List for your 
equipment and domicile. If you are considering making a Standing Bid move, you may also 
wish to download the BidPacks and Bid Awards for another aircraft or domicile, and see 
what kind of lines you would be able to hold in another aircraft, domicile, or seat.  

Suggestion: Create a new folder somewhere on your hard disk and name it “BidPack 
Downloads.” When you download any bidpack-related files from the FedEx website, always 
direct them to this folder. If you don't put the downloaded file(s) in the same place each time, 
you may have trouble locating them after the download is complete.

What's a Document?

You use the BidBest application (program) to create Bid Worksheet documents from 
information in BidPack files. A document is a computer file in which you view, enter, and store 
information. When closed, a document appears as an icon on the desktop.
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In the above window, the icon labelled “BidWorksheet.B727.MAY99.MEM” is a  BidWorksheet 
document (created by BidBest from information in a BidPack file). The BidPack files are 
supplied by FedEx, and you obtain them by downloading from the FedEx website. 

The icon named  “1999_May_B727_MEM_LINES.asc” is a downloaded BidPack file.

The third file, 1999_May_B727_MEM_SENLIST.asc, was also downloaded from the website; it 
is a Bid Seniority List.

When you create or open a Bid Worksheet document, you see its contents displayed in a 
window. You make changes to the document by adding, deleting, or rearranging choices in 
your Bid Choices list.

You can also view a Bid Seniority List or a Bid Award List in a separate window, although you 
can’t make any changes to these files from within BidBest.

The Bid Pack File

The Bidpack file, once uncompressed, is just a straight text file; you can open it with a word 
processor program and read it, make changes to correct typographical errors, and print it out. 
However, it's only a screen display of the same information as the printed Bid Pack, and 
therefore not very useful.

BidBest takes this “'raw” text file and converts it into its own format as a Bid Worksheet 
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document. The Bid Worksheet document displays lines and individual pairings in a graphical 
format and allows you to sort and filter a list of Bid Choices to prepare your bid. The default 
name for a new Bid Worksheet document is  in the format 
“BidWorksheet.B727.MAR97.MEM,” which allows you to distinguish among month, domicile, 
and equipment types.

Running BidBest

Start up BidBest by double-clicking on its icon. In the initial dialog that appears, click on the 
button labelled “New Bid Document.”  In the dialog that follows, find and select the 
(previously downloaded)  BidPack file, and click Open. BidBest will use the selected BidPack file 
to create a new Bid Worksheet.

You can also create a Bid Worksheet document after BidBest is already running. To create a 
document when BidBest is running, choose New from the File menu.

After you have looked at the lines and made some bid choices, Save the Bid Worksheet file to 
your hard disk, to retain all your changes. You can return to it later, by Opening is from within 
BidBest, and take up where you left off working on your bid.

To save a document, choose Save or Save As from the File menu.

– Choose Save to save a document for the first time, or to save changes to a document you’ve 
previously saved.

– Choose Save As to save another version of a document with a new name, or in a separate 
location.

The Bid Worksheet Document Window

In the window are two scrollable lists: the Bidlines List (in the upper right corner of the 
window), and the Bid Choices List (on the left side of the window). There are also two popup 
menus which allow you to control what set of bidlines is displayed in the Bidlines List, a button 
to take you quickly back to a list of all lines after you’ve done a Filter, and some advisory 
information such as the current number of choices in your Bid Choices List, how many lines 
are currently displayed in the Bidlines List, and what type of Filter is currently active, if any.

The Bidlines List:
When a new Bid Worksheet is created, or a saved one opened, the Regular bidlines will be 
displayed in the scrolling Bidlines List. Use the “Line Type” popup menu to switch to a 
display of VTO or Reserve lines instead of the Regular lines.

Double-click on a single line in the Bidlines List to display the line in expanded form. 

A click in the Checkmark column of the Bidlines List, just to the left of the Line Number, 
will add the line to the Bid Choices List. The new choice will be inserted into the list at the 
point indicated by the small draggable sideways triangle to the left of the list. A checkmark 
will appear in the  Checkmark column to indicate that the line has been added to the Bid 
Choices List.
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Clicking in a previously-checked Checkmark column will remove the line from the Bid 
Choices List.

If the Regular Lines are displayed in the Bidlines List, the two columns to the right of the 
bidline summary information allow you to mark individual lines with up to three ‘+’ or ‘–’ 
marks. One click will insert one mark, a second click will add another. Command-click will 
erase all marks on that line; the command “Clear +/– Marks” under the Mark Bidlines 
menu will clear the marks from all displayed lines at once.

If you have marked several lines, you can then use the “Show ‘+’ Marked Lines Only” and 
“Don't Show ‘–’ Marked Lines” Filters to display only marked lines or exclude ‘–’ marked 
lines.

You can display VTO and Reserve lines in the Bidlines List by selecting the corresponding 
command in the popup menu labelled “'Line Type.”

For the 727 only, you may include or exclude the SIBA lines by selecting “'Include SIBA 
Lines,” “'Exclude SIBA Lines,” or “'Show SIBA Lines Only”  in the popup menu labelled 
“'SIBA Screen.”

Filters and Sorts:

The commands under the “Filter” and “Sort” menus apply to whatever is currently 
displayed in the Bidlines List.
Please take note of this: The Filters and Sorts will only   be applied to the lines that are 
displayed in the Bidlines List when you choose the filter or sort command. For example, 
suppose you have done a Filter By Layover Cities and only five lines were found that had 
layovers in the desired city. If you then do a second Filter, that filter will only look at the set 
of five lines found in the first filter. The effect of repeated Filters is cumulative, until you use 
the Show All Lines button or command to display the original set of all lines. The reason for 
this is to allow you to do combined Filters.

You should be able to figure out which Filters and Sorts to apply sequentially in order to 
find the particular types of lines you are interested in or which you wish to avoid.

For example, you could follow a Filter By Layover City command with a Filter By Days Off 
command to find all lines that lay over in LAX and have the first five days of the month off.

Once you find a set of lines that meet your criteria, you can use the Bid All Displayed Lines 
command under the Bid menu to add the lines to your bid choices immediately, or you can 
mark them with '+' marks and then go back to Show All Lines to do more Filters or Sorts.

Example of Using Mark in Conjunction with Filter:

You can use the ‘–’ Marks to exclude certain types of lines: for example, if you wanted to 
exclude all lines containing out-and-backs, first click on the Show All Lines button. Then 
select the command “By Contains Out and Backs” from under the Filter menu. Next, 
choose “Mark All ‘–’” from under the Mark Bidlines menu. At this point, you are displaying 
all lines that contain pairings with out-and-backs, and all are marked ‘–’. 

Click on the Show All Lines button. The out-and-back lines will still be marked ‘-’. When 
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you choose the command “Don't Show ‘–’ Marked Lines” from under the Filter menu, all 
the out-and-back lines will be excluded, and you will have a list of all lines that do not 
include any out-and-backs.

Bid Choices List:

You can add choices to the list by clicking in the check-mark area of a displayed bid line, or 
by using the commands under the Bid menu. Cut and Paste will also work. Insertions will 
occur at the location pointed to by the small black sideways triangle, which is draggable up 
and down.

Double-click on a line number in the Bid Choices List to expand it into a separate window.

Once your Bid Choices List is completed to your liking, Save and/or Print the Bid 
Worksheet, then Quit BidBest.

Note that the Print command will print out a list of the bid choices only, not the entire Bid 
Worksheet document.

Expanded Line Window

In the Expanded Line window, a click on a Pairing button will expand the pairing into its own 
window.

Vacation Bidding:

In the lower right corner of the Expanded Line Window is a “Days — Hours” summary. If 
you drag the mouse over several days with the mouse button down, a block of days will 
be selected. The “Days — Hours” summary will display the total of the number of days 
and credit hours that would be lost for vacation in that period. Once a block of days has 
been selected, you may move it up and down with the up and down cursor keys; this is 
intended to help you evaluate the effect of a vacation slide on a particular line.

You can find the rules for vacation slides and expansions in the Flight Crewmembers 
Handbook, in the section on Benefits.

Seniority List

To display a Bid Seniority List, you must first download it from the FedEx website.  BidBest 
cannot read a compressed file, so if you have downloaded a compressed file, you must expand 
it before trying to open it with BidBest (see the discussion above on file 
compression/expansion utility programs).

From within BidBest, use the Open command in the File menu to locate and open the seniority 
list into its own window. If you supply your employee number when asked, your name, if it is 
in the list, will be drawn in a hilight color and marked with a bullet (•). If you click on the 
“Hide ‘*’ Marked” button, all names with an asterisk (pay only) will be hidden and you can see 
what your effective seniority ranking for the month will be (which is the number of lines you 
must bid to be completely covered).
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The “Find Empl. #” button, when clicked, will scroll your employee number into view (if it is 
anywhere in the list).

Bid Award List

After the bid is awarded, you can download the award from the FedEx web site. Again, 
BidBest can only work with an expanded (un-compressed) file. From within BidBest, use the 
Open command to locate and open an awards file. For an award in which your employee 
number is listed, it's not necessary to supply a seniority number. However, if you want to 
check the award for a different seat or aircraft, you may supply your seniority number to see 
what sort of lines you could hold in that seat/aircraft. Lines that went junior to you will be 
marked with a bullet (•) and drawn in a hilight color.
If a Bid Worksheet window is also open, and it matches the open Bid Award window in bid 
month and equipment, when you double-click on a line in the Bid Award window, the 
awarded line will expand into an Expanded Line window.

Submitting a Bid

If by phone, you can first print out your Bid Worksheet for reference, then punch in your bid 
choices using the touchstone keypad.

If by modem, you can either print out your bid choices list, as above, and use it for reference 
while typing your bid choices into online VIPS, or you can use MacLynx to send them 
automatically (quicker than typing each one in yourself). Start up MacLynx and navigate your 
way to the Monthly Bid section of VIPS. Then choose the Open command from under the File 
menu to locate and open up a window containing your Bid Choices. When this window is 
open, click on its Send Bid button to tell MacLynx to start sending your bid choices over to 
VIPS. 

 If the automatic send gets confused, you can Cancel it by holding down the Command key 
and typing a period ( )

After the Bid Choices have been sent, check each VIPS page of bid choices over carefully! This 
automatic-send feature is intended as a convenience, but it is not guaranteed to work! You are 
responsible for proofing the set of choices that are accepted by VIPS; do not assume that the 
choices have been sent and received without errors.

Drag and Drop

A feature of System 7 is Drag and Drop: this allows you to open an existing BidBest Bid 
Worksheet by dragging its icon over the top of the BidBest program's icon until the BidBest 
icon turns dark, then releasing the mouse button. BidBest should start up and display the 
Worksheet document.

You can do the same with MacLynx; in the latest versions, you can Drag and Drop a BidBest 
Bid Worksheet document's icon over the top of the MacLynx icon and release the mouse 
button. MacLynx will start up and display the Worksheet Bid Choices in a separate window. 
Log on and navigate to the VIPS bid area. When you reach the bid input screen, click once on 
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the Bid Choices window to activate it, then on the Send Bid button to start sending the choices, 
as described above.

Problems

The bid packs occasionally contain typographical and other errors. BidBest can handle some 
errors, but others may cause it to choke. It will attempt to warn you when it encounters 
problems, and will try to continue – if you get a warning during the initial parse of the 
downloaded Bidpack, just be alert for errors.

If the problem is so bad that BidBest can't interpret the file at all, you can open up the 
downloaded Bidpack file using a word processor program and correct the errors yourself, 
then try again with BidBest. Commonly used word processor programs are ClarisWorks, 
MacWrite, and Microsoft Word. 

The one problem with doing this is that BidBest can only read a file of type TEXT. The Bidpack 
downloaded from the FedEx website is a TEXT file, but when you open a TEXT file with a 
word processor program, it translates it into its own format. If you try to Save changes, you 
will be Saving the information into a file of some other type than TEXT, and BidBest will not be 
able to read it. Therefore, instead of Save, do a Save As… and specify that the type of file is 
TEXT (or Text, or ASCII). You may need to refer to the instructions that came with your word 
processor. 

Instructions for ClarisWorks:

To save a document as a file of type TEXT in ClarisWorks, you choose the Save AsÉ  
command from under the File menu. In the dialog that appears, just above the name for 
the new file are the words “Save As:” If you click the mouse on top of these words, a menu 
will drop down giving you a choice of file formats; choose “'Text.”

In ClarisWorks, if you want to be able to view the bid lines correctly, so that the columns 
all line up, you must do the following:

With the Bidpack document opened up in a ClarisWorks window, choose Select All and 
change the Font to Monaco. Change the size to 9 Point.

Choose “'Page Setup” from under the File menu. For Page Size, choose Executive. Choose 
Scaling: 40%. Choose the Orientation icon on the right (sideways orientation). Click on the 
Save button.

After you do all this, each bidline should appear all on one line and lined up correctly.

The Menu Commands

File Menu:

New: Same as clicking on the “'New Bid Document” button in BidBest's initial startup 
(“'What would you like to do?”) dialog. BidBest will ask you to locate a Bidpack file  
(previously downloaded from the FedEx website) which it will use as input in creating a 
new Bid Worksheet document.
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Open: Same as clicking on the “'Open Existing Bid Document” button in BidBest's initial 
startup (“'What would you like to do?”) dialog, except that the button will only let you 
open a Bid Worksheet document, while the Open command will also let you open a 
Seniority List file or a Bid Awards file.

Edit Menu:

Change User Info: Lets you change your personal information as to seat position, 
equipment and domicile.

Window Menu: 

If more than one window is open on the screen, lets you select a particular window and 
bring it to the front.

Pairing Menu:

Display Pairing: Given a valid pairing number, BidBest will display the pairing 
information in a new window.

Filter Menu:

Most of the commands here are self-describing. Remember, they only apply to the list of 
bidlines that is currently displayed in the Bidlines List.

Show All Lines has the same effect as clicking on the “Show All Lines” button in the Bid 
Worksheet window; it has a command-key equivalent for your convenience.

Show Filter Status opens a window to advise you of what filters and final sort, if any, you 
have applied to the bidlines to get the resulting subset that is currently displayed in the 
Bidlines List.

Sort Menu:

Again, most of the commands are straightforward.

Combi Sort allows you to sort lines based on a weighted sort of up to 3 criteria. Each line 
will be looked at and assigned a value based on how well it fits with the requested 
criteria in combination with how much weight you have assigned each criteria (Low to 
High priority). Then the lines will be sorted according to value, and displayed in high to 
low order.

Bid Menu:

The commands in the Bid menu control the Bid Choices list.

Mark Bidlines Menu:

Allow you to mark all displayed lines at once, or clear all marks.
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Questions, Comments, & Bug Reports

Please email me at 

dakota51@ix.netcom.com

– or put a note in my MEM crew mailbox.

Addendum – Features Added to Later Versions

My thanks to Ken Culbertson for suggesting the following extra Sorts, based on information 
not displayed as such in the bid packs. Some folks may find it useful when comparing lines. All 
are available under the Sort menu.

The following time totals include all carryover flying on a line. The summary information 
normally given in the bid pack does not seem to include carryover in its TAFB and Duty Time 
totals, although the Number of Landings total does seem to include carryover flying.

By TAFB/Credit Factor sorts by time away from base divided by credit hours: This gives you 
an idea of how long you must be away to earn an hour’s pay.

By Duty/Credit Factor sorts by duty time divided by credit hours: This gives you and idea of 
how long you must be on duty to earn an hour’s pay.

By Avg. BlockHrs/Leg sorts by total block time on the line divided by number of landings:  the 
result is block time per leg, averaged over the entire bid month.

Try Option-double clicking on a particular line; instead of opening it up in condensed format 
(which would happen if you just double-clicked on it), it will open up in a calendar form. You 
can then print the calendar (this is so you can have a printed copy of the line you are 
awarded). This is same as the command “Show Line As Calendar” under the Window menu.

(suggested by Tom Garrett) If you Shift-double-click on a particular line, it will open up in an 
“old-fashioned” format that is similar to the format of the printed bid packs.

Also under the Window menu is “All Pairings on Line.” If you select this command when a 
line is selected in the main window, you will get a window containing the text of all pairings on 
that line. This is also printable, so you can quickly print a list of all the pairings you will be 
flying in a particular month.

Recent Changes:

• Three new Sorts/Filters (added at the request of users):

1) Filter by Lines Range…: Added because the MD-11 breaks out the Captain and 
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FO/RFO trips into separate lines. If, for example, you are an MD-11 Captain and the 
Captain lines begin with 1 and run through 51, you can filter the lines so as to display 
Lines 1 through 51 only.

2) Sort by Total # Pairings: This will give you an idea of how many departures from 
domicile are on the line.

3) Sort by Credit/DaysOn Factor: A user suggested this to get the effect of an “efficiency 
index” calculation by which he evaluates the lines. When doing the sort, the program first 
counts the number of days “on” (working days) that are on the line. You can specify that 
days off that are not in a block of a certain minimum length will be counted as “working” 
days (for commuters). Then the program divides the total credit hours for the line (not 
counting carryover) by the number of days “on”. An “efficient” line would approach 7 
hours (under the current 7 hr. per day duty rig). Please note that this is a rough 
approximation only! The program does  not automatically exclude days off that are in 
blocks less than the minimum length you specified if they are at the beginning or end of 
the bid month (since it has no idea of what your schedule is like for the preceding or 
following month).

• Since all MD-11 lines require frequent use of the “Show Lines Range” filter, I’ve added a 
checkbox near the bottom of the main window to allow you to lock in a lines range. 

• Modified the Filter by Layover City so that following the filter, it will sort on either the 
number of pairings on the line, or the length of the layover (approximate).

• Added Sort by Max Block Hours

• Added a Show Bid Choices: Bidpack Format to the Window menu, so that you can display 
your current bid choices one above another in a separate window.

• If parse of file is bad, the program will display the WhatNext dialog instead of a blank screen 
(saves a little time & mouse clicks).

• Added the ability to display and print a calendar showing the pairings on a single line (hold 
down Option key when double-clicking on a line in the main window). 

• Added the ability to display and print the text of all the pairings on a single line.
  
• Added a filter for pairing report time (before or later than a specified time) – “Filter by 
Report Time…”

• Added feature: the program now retains filter request info when Saved.

• Added feature: can now specify what pairing num the SIBA pairings start with.

• Added filter to show only lines in a certain range (so MD-11 F/O’s could block out lines 
lower than 101).

Tip:
 Once you have created a new Bid Worksheet and Saved it to your hard disk drive, create an 
alias to it and put the alias in the same folder as BidBest. Then when you want to open that Bid 
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Worksheet up the next time, drag the icon of the alias over the top of the BidBest icon. This 
will cause BidBest to start up and open the worksheet, without your having to go through the 
initial startup dialog. (To make an alias of a file: from the Finder, click once on the file’s icon to 
select it. Then choose “Make Alias” from under the File menu).
Recent changes to BidBest:
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